最火下载站首页
手机版
最火下载站
关注公众号
最火下载站

当前位置:首页 > 网络知识 > 编程开发 > 其它语言> 利用易语言自带的加密解密功能实现账号密码的加密存储

利用易语言自带的加密解密功能实现账号密码的加密存储

文章作者:网友投稿 发布时间:2013-05-24 14:59:45 来源:网络

大家写程序为了用户操作方便,经常需要实现自动记忆功能。用写配置文件的方式可以记忆很多内容,但是如果是记忆账号密码的话,明码存储可就不大好了。尤其是比如淘宝网的应用,存储

大家写程序为了用户操作方便,经常需要实现自动记忆功能。用写配置文件的方式可以记忆很多内容,但是如果是记忆账号密码的话,明码存储可就不大好了。尤其是比如淘宝网的应用,存储的是淘宝的账号密码,这个无论如何也不该明码存储的。

利用易语言自带的加密解密功能,可以很好的实现账号密码的加密存储:

保存:
写到文件 (取运行目录 () + “\user.dat”, 加密数据 (到字节集 (编辑框_账号.内容 + “||” + 编辑框_密码.内容), “淘宝”, ))

读取:
.版本 2
.支持库 dp1

.子程序 __启动窗口_创建完毕
.局部变量 临时文本, 文本型
.局部变量 分割, 文本型, , "0"

.如果真 (文件是否存在 (取运行目录 () + “\user.dat”))
临时文本 = 到文本 (解密数据 (读入文件 (取运行目录 () + “\user.dat”), “淘宝”, ))
分割 = 分割文本 (临时文本, “||”, )
编辑框_账号.内容 = 分割 [1]
编辑框_密码.内容 = 分割 [2]

其中的 || 和 “淘宝” 可以自定义。以此记录的账号密码数据,在不知道分隔符和加密KEY的情况下是很难破解的。

上一篇: 易语言e.exe在一些系统运行出错解决方法

下一篇: Windows2003下易语言点支持库配置就退出的问题

共有0条评论网友评论
游戏