最火下载站首页
手机版
最火下载站
关注公众号
最火下载站

当前位置:首页 > 网络知识 > 网络编程 > JSP教程> 应用教程:解决jsp开发中不支持EL问题

应用教程:解决jsp开发中不支持EL问题

文章作者:网友投稿 发布时间:2008-12-11 21:02:07 来源:网络

烈火建站网文档 今天遇到了一个莫名其妙的问题,就是在使用MyEclipse5.5或6.0时遇上了解析不到EL表达式的问题。经过好几个小时的琢磨终于发现了,给大家share一下: 问题就出在建Web Project的时候web.xml声明上。 web.xml声明部分一般分为如下版本的xsd, web-app_2_2.dtd

烈火建站学院文档 今天遇到了一个莫名其妙的问题,就是在使用MyEclipse5.5或6.0时遇上了解析不到EL表达式的问题。经过好几个小时的琢磨终于发现了,给大家share一下:
问题就出在建Web Project的时候web.xml声明上。
web.xml声明部分一般分为如下版本的xsd,
web-app_2_2.dtd
web-app_2_3.dtd
web-app_2_4.xsd
web-app_2_5.xsd

更详细的列出各版本web.xml声明部分吧,如下:
web-app_2_2.dtd

   
"http://java.sun.com/dtd/web-app_2_2.dtd">  

web-app_2_3.xsd

   
"http://java.sun.com/dtd/web-app_2_3.dtd">  

web-app_2_4.xsd

   
  

web-app_2_5.xsd

   
  

注意!! 其中servlets 2.4(我没记错的话JSP 2.0出来之后的第一个版本),这个版本的isELIgnored默认设置为false。所以使用web.xml里用web-app_2_4.xsd声明的时候在JSP页面不用特意声明。 servlets 2.4EL可以直接使用。

而其它的不行必须手工申明.
确定web.xml里的xsd版本之后(如果不是servlets 2.4)一定要在JSP的声明(<%@page %>)部分加一行,如下:
<%@ page isELIgnored="false" %>
或者
设置整个项目使用el表达式,需要在web.xml中加上 (控制一个项目)


false


这样设为false才能解析EL表达式。

还用一个最简单的解决方法是,直接在web.xml中将servlets 2.4xsd的引用替换你现在的。即用以下引用替换.
 

上一篇: JSP/SERVLET中文编码问题的研究总结

下一篇: JSP新手易出现的问题 一步一步教你解决

共有0条评论网友评论
游戏