软件下载 | 资讯教程 | 最近更新 | 下载排行 | 一键转帖 | 发布投稿
您的位置:最火下载站 > 下载中心 > 开发制作 > 易语言类 > 精易皮肤模块 v1.0 官方版下载

精易皮肤模块 v1.0 官方版

  • 软件语言:简体中文
  • 软件类型:国产软件
  • 软件大小:861 KB
  • 软件等级:3星级
  • 相关链接:Home Page
  • 软件授权:免费版
运行环境:Windows
更新时间:2015-06-28 16:58:11
有无插件:无插件,请您放心使用!

精易皮肤模块来自精易官方网站,内附模块使用例程、皮肤_QQ影音.she、精易皮肤模块1.0.ec和SkinH_EL.dll文件,下图为示例界面

精易皮肤模块

引入的模块界面:

精易皮肤模块

模块信息:

.版本 2

.子程序 Skin_初始化, , 公开, 如果SkinH_EL.dll放在程序根目录下,或者系统的system32下,可不用初始化
.参数 SkinH_EL文件路径, 文本型, , SkinH_EL.dll文件路径,下载地址: http://115.com/file/aqa4ipe4

.子程序 Skin_换肤类型, 逻辑型, 公开, 指定窗体和控件的换肤类型,成功返回真,失败返回假 如果控件无法加到上皮肤,请用此命令
.参数 句柄, 整数型
.参数 换肤类型, 整数型, , 5001=文本框 5002=窗体 5003=颜色选择器

.子程序 Skin_绘制元素, 逻辑型, 公开, 绘制指定设备上下文的元素,成功返回真
.参数 窗口或控件句柄, 整数型, , 目标窗口或控件的句柄
.参数 左上角水平坐标, 整数型
.参数 左上角垂直坐标, 整数型
.参数 右下角水平坐标, 整数型
.参数 右下角垂直坐标, 整数型
.参数 控件id, 整数型

.子程序 Skin_加载, 逻辑型, 公开, 加载程序当前目录下的skinh.she皮肤,成功返回真

.子程序 Skin_加载_从文件1, 逻辑型, 公开, 加载指定的皮肤,成功返回真
.参数 皮肤路径, 文本型, , 皮肤文件路径
.参数 皮肤口令, 文本型, 可空, 皮肤密钥

.子程序 Skin_加载_从文件2, 逻辑型, 公开, 加载指定皮肤,并指定皮肤的色调,饱和度,亮度, 成功返回真
.参数 皮肤路径, 文本型, , 皮肤文件路径
.参数 皮肤密码, 文本型, 可空, 皮肤密钥
.参数 色调, 整数型, 可空, 取值范围 -180-180
.参数 饱和度, 整数型, 可空, 取值范围 -100-100
.参数 亮度, 整数型, 可空, 取值范围 -100-100

.子程序 Skin_加载_从资源, 逻辑型, 公开, 从资源添加皮肤,并指定皮肤的色调,饱和度,亮度,成功返回真
.参数 资源皮肤, 字节集, , 皮肤数据
.参数 皮肤密码, 文本型, 可空, 皮肤密钥
.参数 色调, 整数型, 可空, 取值范围 -180-180
.参数 饱和度, 整数型, 可空, 取值范围 -100-100
.参数 亮度, 整数型, 可空, 取值范围 -100-100

.子程序 Skin_取控件坐标颜色, 整数型, 公开, 获取指定窗口或控件在nX,nY处的颜色值,无符号整型 返回颜色值(RGB)
.参数 句柄, 整数型, , 指定窗口或控件的句柄
.参数 横坐标, 整数型, , 指定横坐标点
.参数 纵坐标, 整数型, , 指定纵坐标点

.子程序 Skin_设置窗口阴影, 逻辑型, 公开, 开启Vista特效,设置阴影
.参数 句柄, 整数型, , 0=取消阴影 1=设置阴影

.子程序 Skin_设置窗体透明, 逻辑型, 公开, 设置窗体透明,成功返回真
.参数 透明度, 整数型, , 1-255 默认值0
.参数 亮度, 整数型, , 1-255 默认值0
.参数 锐度, 整数型, , 1-255 默认值0
.参数 阴影大小, 整数型, , 2-19 默认值0
.参数 水平偏移, 整数型, , 默认值0
.参数 垂直偏移, 整数型, , 默认值0
.参数 红色分量, 整数型, , 0-255 默认值 -1
.参数 绿色分量, 整数型, , 0-255 默认值 -1
.参数 蓝色分量, 整数型, , 0-255 默认值 -1

.子程序 Skin_是否已签名, 逻辑型, 公开, 返回签名结果 已签名返回真,未签名返回假

.子程序 Skin_是否重画, 逻辑型, 公开, 用于填充表格或者列表控件数据时,重复绘制滚动条影响执行效率问题。成功返回真
.参数 句柄, 整数型, , 窗口或控件的句柄
.参数 是否锁定, 整数型, , 是否锁定。1为锁定,0为解锁

.子程序 Skin_调整色调, 逻辑型, 公开, 调整窗口色调,成功返回真
.参数 色调, 整数型, , 取值范围 -180-180
.参数 饱和度, 整数型, , 取值范围 -100-100
.参数 亮度, 整数型, , 取值范围 -100-100

.子程序 Skin_卸载, 逻辑型, 公开, 卸载换肤 (注意:在换肤或者程序退出时换肤库会自动卸载当前皮肤,无需再调用此接口进行卸载)

.子程序 Skin_卸载指定控件, 逻辑型, 公开, 卸载指定句柄的窗体或者控件的皮肤,成功返回真
.参数 句柄, 整数型, , 指定窗体或控件的句柄

.子程序 Skin_置菜单到标题栏, 逻辑型, 公开, 把窗口菜单设置到窗口的标题栏上去
.参数 窗口句柄, 整数型
.参数 是否设置, 逻辑型, , 是否设置到把菜单设置到标题栏上去
.参数 菜单栏高度, 整数型, 可空
.参数 上部偏移, 整数型, 可空
.参数 右部偏移, 整数型, 可空

.子程序 Skin_置菜单透明度, 逻辑型, 公开, 设置菜单透明度
.参数 透明度, 整数型, , 取值范围 0-255

.子程序 Skin_置窗口可否移动, 逻辑型, 公开, 设置窗体是否可以移动
.参数 窗口句柄, 整数型
.参数 是否可移动, 整数型, , 0为不可移动,1为可移动

.子程序 Skin_置窗口透明度, 逻辑型, 公开, 设置指定句柄的窗体的透明度,成功返回0
.参数 句柄, 整数型, , 指定窗体句柄
.参数 透明度, 整数型, , 取值范围 0-255

.子程序 Skin_置控件背景色, 逻辑型, 公开, 设置控件的背景色(目前仅对单选框,复选框,分组框有效)
.参数 控件句柄, 整数型
.参数 红色分量, 整数型
.参数 绿色分量, 整数型
.参数 蓝色分量, 整数型

.子程序 Skin_置控件文本色, 逻辑型, 公开, 设置控件的文本颜色色(目前仅对单选框,复选框,分组框有效)
.参数 控件句柄, 整数型
.参数 红色分量, 整数型
.参数 绿色分量, 整数型
.参数 蓝色分量, 整数型

.子程序 皮肤_导出, 逻辑型, 公开, 导出自己喜欢的皮肤,在外部用dll(Skin_加载)调用方式加载皮肤
.参数 皮肤, 字节集, , 要导入的皮肤,以 #皮肤_ 开头 如 #皮肤_QQ2011
.参数 导入文件路径, 文本型, , 要保存皮肤的路径,如: C:\皮肤_QQ2011.she

.子程序 皮肤_加载, , 公开, 内存皮肤下载地址:http://e.3600gz.cn/a/gongjuxiazai/nacunpifu/
.参数 皮肤, 字节集, , 可直接用 读入文件("皮肤文件")或者放在图片资源表里
.参数 色调, 整数型, 可空, 取值范围-180-180,默认值0
.参数 亮度, 整数型, 可空, 取值范围-100-100,默认值0

.子程序 皮肤_释放, , 公开, 在程序结束前前用上这一句,把皮肤内存释放掉;

.子程序 皮肤_锁定, , 公开, 有助表格或列表效率问题
.参数 句柄, 整数型, , 控件句柄
.参数 锁定, 逻辑型, 可空

.子程序 皮肤_卸载, , 公开, 结束前执行,释放内存

.子程序 皮肤_颜色调整, , 公开
.参数 色调, 整数型, 可空, 取值范围-180-180,默认值0
.参数 亮度, 整数型, 可空, 取值范围-100-100,默认值0

.子程序 皮肤_阴影特效, , 公开
.参数 有效性, 逻辑型, 可空

.子程序 皮肤_置菜单到标题栏, , 公开, 一旦设置上,将无法取消
.参数 窗口句柄, 整数型
.参数 向左部偏移, 整数型, 可空, 单位为像素,数值越大,超往标题这边靠

.图片 皮肤_Adamant, 公开
.图片 皮肤_Areo, 公开
.图片 皮肤_Asus, 公开
.图片 皮肤_Black, 公开
.图片 皮肤_compact, 公开, 可直接使用 皮肤_导出() 命令把自己想要的皮肤导出
.图片 皮肤_Dogmax, 公开
.图片 皮肤_Itunes, 公开
.图片 皮肤_Longhorn, 公开
.图片 皮肤_Mancity窄版, 公开
.图片 皮肤_MSN, 公开
.图片 皮肤_Office_2007, 公开
.图片 皮肤_QQ2008, 公开
.图片 皮肤_QQ2009, 公开
.图片 皮肤_QQ2009_宽底边, 公开
.图片 皮肤_QQ2009_窄底边, 公开
.图片 皮肤_QQ2009黑色, 公开
.图片 皮肤_QQ2011, 公开
.图片 皮肤_QQGame, 公开
.图片 皮肤_QQTalkSHE, 公开
.图片 皮肤_QQ金属雅灰, 公开
.图片 皮肤_QQ影音, 公开
.图片 皮肤_REAL, 公开
.图片 皮肤_ShanMeng窄版, 公开
.图片 皮肤_Storm, 公开
.图片 皮肤_WhiteFire, 公开
.图片 皮肤_xmp, 公开
.图片 皮肤_纯净皮肤, 公开
.图片 皮肤_彗星小助手深蓝色, 公开
.图片 皮肤_积木, 公开
.图片 皮肤_悬浮镂空, 公开
.图片 皮肤_炫绿, 公开
.图片 皮肤_中国风, 公开

 报告下载错误
点击链接开始下载
本类最新
相关教程
下载说明
栏目导航
推荐软件