软件下载 | 资讯教程 | 最近更新 | 下载排行 | 一键转帖 | 发布投稿
您的位置:最火下载站 > 软件下载 > 开发制作 > 易语言类 > 易语言黑羽模块 v1.0 免费版下载

易语言黑羽模块 v1.0 免费版

  • 软件语言:简体中文 / 国产软件
  • 软件大小:15 KB
  • 软件等级:3星级
  • 相关链接:Home Page
  • 有无插件:无插件,请您放心使用!
  • 软件授权:免费版
  • 更新时间:2013-04-08 17:22:46
  • 运行环境:WinXP/Win2003/Vista/Windows7

易语言黑羽模块

模块名称:黒羽模块
作者:黑羽工作室
版本:1.0

黒羽模块
@备注:
黑羽工作室专用模块 By:羽落

.版本 2

.子程序 八到十, 整数型, 公开, 将八进制转换成十进制(返回十进制整数)
.参数 八进制文本, 文本型, , 欲转换的八进制文本

.子程序 撤消文件关联, 逻辑型, 公开, 成功返回真,失败返回假
.参数 关联文件后缀, 文本型, , 欲撤消的文件后缀,如txt

.子程序 初始化线程COM库, , 公开, 有时执行线程的时候,会自动关闭,此时,可以在多线程的程序里创建COM对象前先初始化,一个线程只能调用一次

.子程序 窗口拖动, 整数型, 公开, 放在组件被按下事件下,拖动指定的窗口,用于自绘界面时使用
.参数 窗口, 窗口, , 欲拖动的窗口

.子程序 到任意进制, 文本型, 公开, 可以将从二进制到三十六进制的数值随意进行转换(返回转换后的文本)
.参数 被转换文本, 文本型, , 欲被转换的文本(不可以转换负数以及小数)
.参数 被转换进制, 整数型, , 被转换文本的进制(2-36之间)
.参数 转换的进制, 整数型, , 要转换到的进制(2-36之间)

.子程序 到十进制, 整数型, 公开, 将2,8,16进制文件转换到10进制数值(返回十进制数)
.参数 文本, 文本型, , 2,8,16进制文件
.参数 进制, 整数型, 可空, 默认为十六进制 2为二进制,8为八进制,16为16进制

.子程序 读内存长整数型, 长整数型, 公开, 从内存中读取长整数型数据,失败返回失败内容
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 失败内容, 长整数型, 可空, 读内存失败后返回值的内容 默认为-1

.子程序 读内存短整数型, 短整数型, 公开, 从内存中读取短整数型数据,失败返回失败内容
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 失败内容, 短整数型, 可空, 读内存失败后返回值的内容 默认为-1

.子程序 读内存日期时间型, 日期时间型, 公开, 从内存中读取日期时间型数据,失败将返回100年1月1日
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址

.子程序 读内存双精度小数型, 双精度小数型, 公开, 从内存中读取双精度小数型数据,失败返回失败内容
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 失败内容, 双精度小数型, 可空, 读内存失败后返回值的内容 默认为-1

.子程序 读内存文本型, 文本型, 公开, 从内存中读取文本型数据(返回文本,失败返回0字节长度空内容)
.参数 进程ID, 整数型
.参数 内存地址, 整数型

.子程序 读内存小数型, 小数型, 公开, 从内存中读取小数型数据,失败返回失败内容
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 失败内容, 小数型, 可空, 读内存失败后返回值的内容 默认为-1

.子程序 读内存整数型, 整数型, 公开, 从内存中读取整数型数据,失败返回失败内容
.参数 进程ID, 整数型
.参数 内存地址, 整数型
.参数 失败内容, 整数型, 可空, 读内存失败后返回值的内容 默认为-1

.子程序 读内存子程序指针, 子程序指针, 公开, 从内存中读取子程序指针,失败返回空指针
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址

.子程序 读内存字节集, 字节集, 公开, 从内存中读取字节集数据(返回字节集,失败返回0字节长度的空字节集)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 长度, 整数型, 可空, 欲读取内存数据的长度 (留空则智能读取)

.子程序 读内存字节型, 字节型, 公开, 从内存中读取一个字节,失败返回失败内容(0-255)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 失败内容, 字节型, 可空, 读内存失败后返回的内容 默认为0

.子程序 读偏移双精度小数型, 双精度小数型, 公开, 读取内存地址数据双精度小数型,共有10个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 读偏移文本型, 整数型, 公开, 读取内存地址数据文本型,共有10个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 读偏移小数型, 小数型, 公开, 读取内存地址数据小数型,共有10个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 读偏移整数型, 整数型, 公开, 读取内存地址数据整数型,共有10个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 二到十, 整数型, 公开, 将二进制转换成十进制(返回十进制整数)
.参数 二进制文本, 文本型, , 欲转换的二进制

.子程序 进程取ID, 整数型, 公开, 取指定进程的进程ID(返回第一个进程ID,失败返回-1)
.参数 进程名, 文本型, , 程序进程名
.参数 区分大小写, 逻辑型, 可空, 默认不区分进程名大小写

.子程序 进程是否存在, 逻辑型, 公开, 判断指定进程是否存在(此判断与进程其它信息无关联)(存在返回真,不存在或失败返回假)
.参数 进程名, 文本型, , 欲检测的进程名

.子程序 内存搜索, 整数型, 公开, 进行首次内存搜索(返回结果数目,失败或没有返回0)
.参数 进程ID, 整数型, , 进程ID
.参数 搜索内容, 字节集, , 欲搜索的内容 其他类型-需自行转换为字节集类型
.参数 结果地址, 整数型, 数组, 用来保存搜索的结果

.子程序 内存搜索整数, 整数型, 公开, 针对上次的搜索进行对内存数值的变化进行再一次搜索(返回结果数目,失败或没有返回0)
.参数 结果地址, 整数型, 数组, 用来保存搜索的结果
.参数 搜索的整数, 整数型, , 从上一次搜索结果地址中再次搜索的整数,也可以是模糊搜索 #内存_不变的数值 #内存_变大的数值 #内存_变小的数值 #内存_改变的数值

.子程序 内存优化, , 公开, 内存优化,其实就是将实际内存转移至虚拟内存,以减少内存占用,周期中使用

.子程序 内存再次搜索, 整数型, 公开, 针对上次的搜索进行再一次搜索(返回结果数目,失败或没有返回0)
.参数 结果地址, 整数型, 数组, 用来保存搜索的结果
.参数 搜索的数据, 字节集, , 从上一次搜索结果地址中再次搜索的数据内容

.子程序 启动项是否存在, 逻辑型, 公开, 判断开机启动项是否存在,存在返回真,不存在返回假
.参数 写入名称, 文本型, , 写入注册表的名称

.子程序 取关联文件文件名, 文本型, 公开, 返回关联文件的文件名,方便用程序打开关联文件,如果不是用关联文件打开而是直接打开程序,则返回空文本

.子程序 取消线程COM库, , 公开, 取消COM库的初始化,如果你在线程头部加入了 线程_初始化COM库 请在尾部加入此命令;

.子程序 去除文本右边, 文本型, 公开, 去除文本右边指定长度,返回去除后的文本
.参数 文本, 文本型, , 待去除的文本
.参数 去除长度, 整数型, , 欲去除文本的长度

.子程序 去除文本中间, 文本型, 公开, 去除文本中间指定长度,返回去除后的文本
.参数 文本, 文本型, , 待去除的文本
.参数 去除起始位置, 整数型, , 欲去除文本的起始位置
.参数 去除长度, 整数型, , 欲去除文本的长度

.子程序 去除文本左边, 文本型, 公开, 去除文本左边指定长度,返回去除后的文本
.参数 文本, 文本型, , 待去除的文本
.参数 去除长度, 整数型, , 欲去除文本的长度

.子程序 去除文件名路径, 文本型, 公开, 此命令用来去除文件名中的路径
.参数 带路径文件名, 文本型, , 带全路径的文件名

.子程序 删除启动项, 逻辑型, 公开, 删除开机启动项,成功返回真,失败返回假
.参数 写入名称, 文本型, , 写入注册表的名称

.子程序 十到八, 文本型, 公开, 将十进制转换成八进制(返回八进制文本)
.参数 十进制数, 长整数型, , 欲转换的十进制数

.子程序 十到二, 文本型, 公开, 将十进制转换成二进制(返回二进制文本)
.参数 十进制数, 整数型, , 欲转换的十进制

.子程序 十到十六, 文本型, 公开, 将十进制转换成十六进制(返回十六进制文本)
.参数 十进制数, 长整数型, , 待转换的十进制数
.参数 是否不去零, 逻辑型, 可空, 默认为假:去0 真:不去0

.子程序 十六到十, 整数型, 公开, 将十六进制转换成十进制(返回十进制文本)
.参数 十六进制文本, 文本型, , 待转换的十六进制文本
.参数 返回结果, 文本型, 参考 可空, 返回文本结果(如十进制数超出整数范围,可通过返回结果获得十进制文本)

.子程序 提升进程权限, 逻辑型, 公开, 提升进程到指定权限( #备份_ #启动_ #关机_ #调试_)
.参数 目标进程, 整数型, 可空, 为空表示当前线程
.参数 权限类别, 文本型, 可空, 为空:#调试

.子程序 文件关联, 逻辑型, 公开, 成功返回真,失败返回假
.参数 关联应用程序路径, 文本型, , 当双击对应的文件时就运行该应用程序
.参数 关联文件后缀, 文本型, , 欲关联的文件后缀,如txt
.参数 关联文件图标, 文本型, , ico文件路径或exe文件路径,注销后才有效

.子程序 写内存双精度小数型, 逻辑型, 公开, 往内存中写入双精度小数型数据(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 变量, 双精度小数型, , 写入数据

.子程序 写内存文本型, 逻辑型, 公开, 往内存中写入文本数据(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 内容, 文本型, , 写入数据

.子程序 写内存小数型, 逻辑型, 公开, 往内存中写入小数型数据(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 变量, 小数型, , 写入数据

.子程序 写内存整数型, 逻辑型, 公开, 往内存中写入四字节数据(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 变量, 整数型, , 写入数据

.子程序 写内存字节集, 逻辑型, 公开, 往内存中写入字节集数据(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 地址, 整数型, , 内存地址
.参数 数据, 字节集, , 写入数据 如果为其它数据类型,可以用 到字节集() 将数据转换为字节集
.参数 写入长度, 整数型, 可空, 默认为全部数据,(参考: 1字节型 2短整数型 4长整数型,小数型,指针 8长整数型,双精度小数型,日期时间型)

.子程序 写偏移双精度小数型, 逻辑型, 公开, 写入内存地址数据双精度小数型,共有11个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 写入数值, 双精度小数型, , 欲写入的数值
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 写偏移文本型, 逻辑型, 公开, 写入内存地址数据文本型,共有11个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 写入文本, 文本型, , 欲写入的数值
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 写偏移小数型, 逻辑型, 公开, 写入内存地址数据小数型,共有11个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 写入数值, 小数型, , 欲写入的数值
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 写偏移整数型, 逻辑型, 公开, 写入内存地址数据整数型,共有11个参数,其中8个偏移量可空
.参数 进程ID, 整数型, , 游戏进程标识符
.参数 基址, 文本型, , 欲读取的内存基址(十六进制)
.参数 写入数值, 整数型, , 欲写入的数值
.参数 偏移1, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移2, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移3, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移4, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移5, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移6, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移7, 文本型, 可空, 没有请留空 (十六进制)
.参数 偏移8, 文本型, 可空, 没有请留空 (十六进制)

.子程序 写启动项, 逻辑型, 公开, 写开机启动项,成功返回真,失败返回假
.参数 写入名称, 文本型, , 写入注册表的名称
.参数 欲写入值, 文本型

.子程序 修改双精度小数型, 逻辑型, 公开, 一次性修改所有欲搜索的值(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 欲搜索的值, 文本型, , 欲搜索的值
.参数 修改为, 文本型, , 修改为:
.参数 存储结果, 整数型, 参考 可空 数组, 可用来再次修改,数组为0

.子程序 修改文本型, 逻辑型, 公开, 一次性修改所有欲搜索的值(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 欲搜索的值, 文本型, , 欲搜索的值
.参数 修改为, 文本型, , 修改为:
.参数 存储结果, 整数型, 参考 可空 数组, 可用来再次修改,数组为0

.子程序 修改小数型, 逻辑型, 公开, 一次性修改所有欲搜索的值(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 欲搜索的值, 文本型, , 欲搜索的值
.参数 修改为, 文本型, , 修改为:
.参数 存储结果, 整数型, 参考 可空 数组, 可用来再次修改,数组为0

.子程序 修改整数型, 逻辑型, 公开, 一次性修改所有欲搜索的值(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 欲搜索的值, 文本型, , 欲搜索的值
.参数 修改为, 文本型, , 修改为:
.参数 存储结果, 整数型, 参考 可空 数组, 可用来再次修改,数组为0

.子程序 修改字节集, 逻辑型, 公开, 一次性修改所有欲搜索的值(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 欲搜索的值, 字节集, , 欲搜索的值
.参数 修改为, 字节集, , 修改为:
.参数 存储结果, 整数型, 参考 可空 数组, 可用来再次修改,数组为0

.子程序 再次修改双精度小数型, 逻辑型, 公开, 再次修改(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 再次修改, 文本型, , 再次修改为:
.参数 存储结果, 整数型, 数组, 用来再次修改的数组,数组为0

.子程序 再次修改文本型, 逻辑型, 公开, 再次修改(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 再次修改, 文本型, , 再次修改为:
.参数 存储结果, 整数型, 数组, 用来再次修改的数组,数组为0

.子程序 再次修改小数型, 逻辑型, 公开, 再次修改(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 再次修改, 文本型, , 再次修改为:
.参数 存储结果, 整数型, 数组, 用来再次修改的数组,数组为0

.子程序 再次修改整数型, 逻辑型, 公开, 再次修改(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 再次修改为, 文本型, , 再次修改为:
.参数 存储结果, 整数型, 数组, 用来再次修改的数组,数组为0

.子程序 再次修改字节集, 逻辑型, 公开, 再次修改(成功返回真,失败返回假)
.参数 进程ID, 整数型, , 进程ID
.参数 再次修改为, 字节集, , 再次修改为:
.参数 存储结果, 整数型, 数组, 用来再次修改的数组,数组为0

.程序集 正则表达式类, , 公开

.子程序 查看, , 公开,

.子程序 创建, 逻辑型, 公开, 根据指定的正则表达式文本创建一个正则表达式对象。本对象中的原有内容将被释放
.参数 正则表达式文本, 文本型, , 比如“易语言4\.0(模块|支持库)?”
.参数 被搜索的文本, 文本型
.参数 是否区分大小写, 逻辑型, 可空, 可以留空,默认为假,不区分大小写; 真为区分大小写;本参数指定这个正则表达式在创建成功后进行匹配、搜索、替换时,是否区分大小写;
.参数 是否匹配多行, 逻辑型, 可空, 可以留空,默认为真,允许匹配多行; 如果本成员值为真,字符“^”不仅匹配目标文本的开头,而且匹配目标文本中换行符(字符(10),字符(13)或 #换行符)的后面;字符“$”不仅匹配目标文本的结尾,而且匹配目标文本中换行符的前面。否则字符“^”仅仅匹配目标文本的开头,“$”也仅仅匹配目标文本的结尾。
.参数 是否全局匹配, 逻辑型, 可空, 可以留空,默认为真,全局匹配
.参数 自动替换引号, 逻辑型, 可空, 可空。默认为不替换。说明:正则表达式文本为【formhash" value="7b4aa6c5】,这里面的引号处理起来很麻烦,直接把此参数设置为真,把"换成 #引号 再传进来就可以了,如:【formhash#引号 value=#引号7b4aa6c5】

.子程序 取匹配数量, 整数型, 公开, 取出该正则匹配到的数量

.子程序 取匹配文本, 文本型, 公开, 取出该正则匹配到的文本
.参数 匹配索引, 整数型, , 索引值从1开始
.参数 起始位置, 整数型, 参考 可空, 可以被省略,提供参数数据时只能提供变量。该命令调用成功后,本参数存放取得的子文本在整个被搜索文本中的起始位置

.子程序 取正则文本, 文本型, 公开, 返回以文本形式表示的正则表达式。如果该对象尚未创建,则返回空文本。本命令为高级对象成员命令

.子程序 取子匹配数量, 整数型, 公开, 取出该正则的子表达式匹配到的数量

.子程序 取子匹配文本, 文本型, 公开, 取出该正则的子表达式匹配到的文本
.参数 匹配索引, 整数型, , 索引值从1开始
.参数 子表达式索引, 整数型, , 欲取其值的子表达式,该参数对应与正则表达式中的一个子表达式以圆括号"( )"为标记,索引从1开始
.参数 起始位置, 整数型, 参考 可空, 可以被省略,提供参数数据时只能提供变量。该命令调用成功后,本参数存放取得的子文本在整个被搜索文本中的起始位置

.子程序 替换, 文本型, 公开, 替换在正则表达式查找中找到的文本
.参数 用作替换的文本, 文本型, 可空, 用作替换的文本

.DLL命令 API_查询内存地址信息, 整数型, , "VirtualQueryEx", 公开
.参数 hProcess, 整数型
.参数 lpAddress, 整数型
.参数 info, , 传址
.参数 dwLength, 整数型

.DLL命令 API_创建快照, 整数型, , "CreateToolhelp32Snapshot", 公开
.参数 falg, 整数型
.参数 id, 整数型

.DLL命令 API_打开当前进程, 整数型, , "GetCurrentProcess", 公开, kernel32.dll 打开当前进程伪句柄

.DLL命令 API_打开进程, 整数型, , "OpenProcess", 公开, kernel32.dll
.参数 访问级别, 整数型, , 2035711完全访问
.参数 子进程继承, 整数型, , 0为子进程继承
.参数 进程ID, 整数型, , 要打开的进程标识

.DLL命令 API_打开令牌, 整数型, , "OpenProcessToken", 公开, advapi32.dll打开过程令牌对象
.参数 ProcessHandle, 整数型, , 进程句柄
.参数 DesiredAccess, 整数型, , 权限
.参数 TokenHandle, 整数型, 传址, 令牌句柄

.DLL命令 API_第一个进程, 整数型, , "Process32First", 公开
.参数 h, 整数型
.参数 p,

.DLL命令 API_关闭对象, 整数型, , "CloseHandle", 公开, kernel32.dll
.参数 对象句柄, 整数型

.DLL命令 API_恢复权限, 逻辑型, , "LookupPrivilegeValueA", 公开, advapi32.dll
.参数 lpSystemName, 文本型
.参数 lpName, 文本型
.参数 lpLuid, , 传址

.DLL命令 API_获取令牌特权, 逻辑型, , "AdjustTokenPrivileges", 公开, advapi32.dll
.参数 TokenHandle, 整数型
.参数 DisableAllPrivileges, 整数型
.参数 NewState, , 传址
.参数 BufferLength, 整数型
.参数 PreviousState, , 传址
.参数 ReturnLength, 整数型, 传址

.DLL命令 API_加载COM, , "ole32.dll", "CoInitialize", 公开, 加载COM
.参数 pvReserved, 整数型, , 值为0

.DLL命令 API_内存读文本, 逻辑型, , "ReadProcessMemory", 公开
.参数 hProcess, 整数型
.参数 lpBaseAddress, 整数型
.参数 lpBuffer, 文本型
.参数 nSize, 整数型
.参数 lpNumberOfBytesRead, 整数型, 传址

.DLL命令 API_内存读整数, 整数型, , "ReadProcessMemory", 公开
.参数 hProcess, 整数型
.参数 lpBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 整数型, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存读字节集, 整数型, , "ReadProcessMemory", 公开
.参数 hProcess, 整数型
.参数 lpBaseAddress, 整数型
.参数 lpBuffer, 字节集, 传址
.参数 nSize, 整数型
.参数 lpNumberOfBytesWritten, 整数型

.DLL命令 API_内存写双精度小数型, 整数型, , "WriteProcessMemory", 公开, kernel32.dll
.参数 hProcess, 整数型
.参数 pBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 双精度小数型, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存写文本, 整数型, , "WriteProcessMemory", 公开, kernel32.dll
.参数 hProcess, 整数型
.参数 pBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 文本型, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存写小数型, 整数型, , "WriteProcessMemory", 公开, kernel32.dll
.参数 hProcess, 整数型
.参数 pBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 小数型, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存写整数, 整数型, , "WriteProcessMemory", 公开, kernel32.dll
.参数 hProcess, 整数型
.参数 pBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 整数型, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存写字节集, 整数型, , "WriteProcessMemory", 公开, kernel32.dll
.参数 hProcess, 整数型
.参数 pBaseAddress, 整数型, , 内存地址
.参数 lpBuffer, 字节集, 传址, 数据指针
.参数 nSize, 整数型, , 长度
.参数 lpNumberOfBytesWritten, 整数型, , 实际写出长度

.DLL命令 API_内存优化, 整数型, , "SetProcessWorkingSetSize", 公开
.参数 hProcess, 整数型, , -1
.参数 dwMinimumWorkingSetSize, 整数型, , -1
.参数 dwMaximumWorkingSetSize, 整数型, , -1

.DLL命令 API_取自进程ID, 整数型, , "GetCurrentProcessId", 公开, kernel32.dll

.DLL命令 API_下一个进程, 整数型, , "Process32Next", 公开
.参数 h, 整数型
.参数 p,

.DLL命令 API_卸载COM, , "ole32.dll", "CoUninitialize", 公开, 卸载COM

.常量 备份_, "“SeBackupPrivilege”", 公开, 系统权限
.常量 调试_, "“SeDebugPrivilege”", 公开, 系统权限
.常量 关机_, "“SeShutdownPrivilege”", 公开, 系统权限
.常量 内存_变大的数值, "-2", 公开
.常量 内存_变小的数值, "-3", 公开
.常量 内存_不变的数值, "-1", 公开
.常量 内存_改变的数值, "-4", 公开
.常量 启动_, "“SeRestorePrivilege”", 公开, 系统权限

 报告下载错误
点击链接开始下载
推荐下载
下载说明
栏目导航
推荐软件