软件下载 | 资讯教程 | 最近更新 | 下载排行 | 一键转帖 | 发布投稿
您的位置:最火下载站 > 建站程序 > Blog教程 > Wordpress安装Warning: Cannot modify header...

Wordpress安装Warning: Cannot modify header...

  烈火网(LieHuo.Net)教程 关于 Wordpress安装时出现“Warning: Cannot modify header information – headers already sent by….”

  今天新申请了PHP空间后,高兴的把WordPress装上,上传、解压、更改wp-config.php文件。当这一切都完成开始安装时,出现错误提示“Warning: Cannot modify header information – headers already sent by….”,不理,继续安装,然后登陆后台是继续出现这个错误。

  问题再次出现时,第一反应是空间的问题,可是从网上一查才发现遇到此问题的人不在少数。大部分人的解决方案是:在php.ini文件中加上或者修改成“output_buffering = on”,我试着添加这语句后发现后台登陆页面的提示没有了,但是登陆后的页面依然存在错误,并且后台的操作命令不返回结果。继续网上找答案……其他的解决方案“在程序的最上方加入函数 ob_start();”,还有“将wp-config.php的编码修改成ANSI”,据了解utf-8编码文件含有的bom,但是php4,5都是不支持bom的,所以出错~最终用“将wp-config.php的编码修改成ANSI”的方法解决问题

    相关阅读
    网友评论
    栏目导航
    推荐软件