软件下载 | 资讯教程 | 最近更新 | 下载排行 | 一键转帖 | 发布投稿
您的位置:最火下载站 > 电脑教程 > 编程开发 > 数据库技术 > Oracle Jinitiator 版本太旧或过低怎么办

Oracle Jinitiator 版本太旧或过低怎么办

打开EBS,系统报:FRM-92095: Oracle JInitiator 版本太旧。 请安装版本1.1.8.2或更高版本

(英文的错误信息是:FRM-92095: Oracle JInitiator version too low. Please install version 1.1.8.2 or higher)

解决方法1:

因为今天升级了JRE到Version 7,但实际上现阶段EBS还不能跑在JRE7上。解决方法就是卸载JRE7,重装JRE6.

Reference Note: FRM-92095 Error When Running Forms Using JRE 7 (JRE 1.7) (Doc ID 1348436.1)

如何卸载JRE7:see http://www.java.com/en/download/uninstall.jsp

JRE6的下载地址:http://www.java.com/en/download/manual_v6.jsp

有Oracle Metalink账号的,可以从这里下载旧版本Java/JRE, All Java SE Downloads on MOS (Doc ID 1439822.1)

解决方法2:

升级服务端的JRE版本

升级方法《Enable EBS environments for JRE 7》:http://www.veryhuo.com/a/view/93969.html

解决方法3:

可以尝试下边的方法,

计算机 ->属性 -> 高级系统设置 ->环境变量 -> 系统变量区域,增加一个操作系统级别的环境变量:

变量名:JAVA_TOOL_OPTIONS

变量值:-Djava.vendor="Sun Microsystems Inc."

退出所有浏览器,然后重新登陆,问题应该就解决了。

(这个方法的解释,可以参考:这里)

补充:貌似还真有不少人不会给操作系统加系统参数的,如果你实在不会添加系统变量,可以用我的这个批处理程序,运行后,系统就会自动加此系统变量了。

批处理文件:http://www.veryhuo.com/down/html/93967.html

关于版本旧,另外的说法:

网上一般说是吧jre环境卸载掉然后登陆的时候会自己安装。那么问题就解决。

首先我们需要验证那个版本的才可以使用。这个比较难,一般不知道的话就全部卸载了,让他自己安装的 版本即可。

我这边是发现了这么一个问题。

通过图3所示,我们知道第一个的是没有使用的,最后一个的也是没有使用的。因为今天打开来测试环境,所以如果使用过的话会提示今天又使用的。现在就剩下一个java7 update 25的是今天使用的,因为update 45的是我今天安装的,而且是提示错误之后才安装的,所以先排除这个。我们把没使用的版本的卸载,今天之前使用的版本的卸载。然后测试之后安装的这个版本的,发现可以进入,正常了。这里说明一个问题,是java 6的版本的比较管用,太高版本的可能就会提示错误。

    相关阅读
    栏目导航
    推荐软件