软件下载 | 资讯教程 | 最近更新 | 下载排行 | 一键转帖 | 发布投稿
您的位置:最火下载站 > 建站程序 > Blog教程 > Wordpress出现Please switch to Firefox / Safari的问题

Wordpress出现Please switch to Firefox / Safari的问题

今天安装了wordpress,同时下载并启用WP-o-Matic采集插件,在Wordpress后台进入WPRobot的时候会出现"Please switch to Firefox / Safari"的提示.每次都得用FireFox才能设置WPRobot,很麻烦.

在网上找到一篇一篇帖子,可以解决这个问题.。

方法(英文):

1. Download http://downloads.wordpress.org/plugin/wp-o-matic.1.0RC4.zip from the http://wordpress.org/extend/plugins/wp-o-matic/ page.

2. Using your favorite text editor edit the file

wp-o-matic/wpomatic.php

Go to line 1079 and comment out the two lines from this

if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
die('Please switch to Firefox / Safari');

to this

// if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
// die('Please switch to Firefox / Safari');

方法(中文由烈火-Liehuo.ORG翻译):

1.到http://wordpress.org/extend/plugins/wp-o-matic/ 下载http://downloads.wordpress.org/plugin/wp-o-matic.1.0RC4.zip

2.编辑这个文件wp-o-matic/wpomatic.php,大约在1079行左右看到如下代码:

if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
die('Please switch to Firefox / Safari');

替换为:

// if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
// die('Please switch to Firefox / Safari');

    相关阅读
    栏目导航
    推荐软件